[重要安全性通知] 发现假冒 Qfinder Pro 网站。了解详情 >

Why I'm not able to connect to the NAS via SSH since update to QTS 5.1.8 / QuTS h5.1.8 and QTS 5.2.0 / QuTS h5.2.0?


最后修订日期: 2024-10-01

Applicable Products

  • QTS 5.1.8 and QTS 5.2.0
  • QuTS h5.1.8 and QuTS h5.2.0

Overview

QTS 5.1.8 / QuTS h5.1.8 and QTS 5.2.0 / QuTS h5.2.0 have updated OpenSSH to version 9.8p1, making some legacy algorithms obsolete. This update affects SSH connections, Rsync encryption, and SFTP.

Below are the supported host-key algorithms:

  • rsa-sha2-256
  • rsa-sha2-512

Recommendation

To avoid connection issues ("no hostkey alg" or "Corrupted MAC on input" error), we recommend the following:

  • Use the latest versions for third-party SSH clients such as PuTTY, MobaXterm, WinSCP, FileZilla, etc. If your client supports these algorithms but still fails to connect, adding the appropriate options with the specified algorithms, as shown above, should resolve the issue.
  • For Windows PowerShell, connect with the following command:
    ssh -m hmac-sha2-256 NAS_ADMIN@NAS_IP

这篇文章有帮助吗?

谢谢您,我们已经收到您的意见。

需要进一步协助,欢迎前往官方社区发帖,与其他用户及 QNAP 专家交流。 前往 QNAP 官方社区

请告诉我们如何改进这篇文章:

如果您想提供其他意见,请于下方输入。

选择规格

      显示更多 隐藏更多
      欢迎随时咨询! 欢迎随时咨询!
      back to top