Applicable Products
QTS, QuTS hero, QuLog Center, App Center
Scenario
You migrated disks from a NAS device running QTS or QuTS hero versions earlier than 5.2.0 to a NAS running QTS or QuTS hero version 5.2.0 or later and after migration you are unable to update or open certain apps such as QuLog Center in App Center.
Root Cause
This issue occurs when the source and destination devices use different firmware versions. To successfully migrate disks from one device to another device without issues, the firmware versions of the devices must be the same. If the firmware versions of the source and destination devices are different, the system will not stop you from migrating the disks, but certain apps or services on the destination NAS may not function correctly.
Solutions
To resolve issues after migrating disks, you can update the firmware or reinstall the firmware on the destination device.
Warning
- To prevent data loss, QNAP recommends backing up all data on your device before updating the firmware.
- Do not power off your device during the firmware update process.
- Before updating the firmware, read through the "System Settings > Firmware Update > Firmware update requirements" in the QTS User Guide or QuTS hero User Guide.
Tip
If you update or reinstall the firmware on the destination device after migrating the disks but QuLog Center or other apps still fail to open or update, there may be other issues preventing the app from functioning normally. For further assistance, you can contact
QNAP Customer Support.
Update firmware
Update the firmware on the destination device to a higher version than currently installed. You can update the firmware using one of the following methods:
- Use the Check for Updates button in Control Panel > Firmware Update.
For details, see the section "System Settings > Firmware Update > Checking for updates" in the QTS User Guide or QuTS hero User Guide. - Download an installation file for a newer firmware version and manually install the firmware file.
For details, see the section "System Settings > Firmware Update > Updating the firmware manually" in the QTS User Guide or QuTS hero User Guide.
Reinstall firmware
Manually reinstall the firmware on the destination device:
- Download the installation file for the current firmware version used by the destination device and then manually install the firmware file.
For details, see the section "System Settings > Firmware Update > Updating the firmware manually" in the QTS User Guide or QuTS hero User Guide.
Further Reading
QTS User Guide
QuTS hero User Guide
适用产品
QTS, QuTS hero, QuLog Center, App Center
场景
您将磁盘从运行 QTS 或 QuTS hero 版本低于 5.2.0 的 NAS 设备迁移到运行 QTS 或 QuTS hero 版本 5.2.0 或更高版本的 NAS 后,无法更新或打开某些应用程序,例如 App Center 中的 QuLog Center。
根本原因
当源设备和目标设备使用不同的固件版本时,会出现此问题。要成功地将磁盘从一个设备迁移到另一个设备而不出现问题,设备的固件版本必须相同。如果源设备和目标设备的固件版本不同,系统不会阻止您迁移磁盘,但目标 NAS 上的某些应用程序或服务可能无法正常运行。
解决方案
要解决迁移磁盘后的问题,您可以更新固件或在目标设备上重新安装固件。
警告
- 为了防止数据丢失,QNAP 建议在更新固件之前备份设备上的所有数据。
- 在固件更新过程中,请勿关闭设备电源。
- 在更新固件之前,请阅读 QTS 用户指南 或QuTS hero 用户指南 中的“系统设置 > 固件更新 > 固件更新要求”。
提示
如果在迁移磁盘后更新或重新安装目标设备上的固件,但 QuLog Center 或其他应用程序仍无法打开或更新,可能有其他问题阻止应用程序正常运行。如需进一步帮助,您可以联系
QNAP 客户支持 。
更新固件
将目标设备上的固件更新到比当前安装的版本更高的版本。您可以使用以下方法之一更新固件:
- 在 控制台 > 固件更新 中使用 检查更新 按钮。
有关详细信息,请参阅 QTS 用户指南 或QuTS hero 用户指南 中的“系统设置 > 固件更新 > 检查更新”部分。 - 下载一个较新版本的固件安装文件,并手动安装固件文件。
详细信息请参见 QTS 用户指南 或QuTS hero 用户指南 中的“系统设置 > 固件更新 > 手动更新固件”部分。
重新安装固件
在目标设备上手动重新安装固件:
- 下载目标设备当前使用的固件版本的安装文件,然后手动安装固件文件。
详细信息请参见 QTS 用户指南 或QuTS hero 用户指南 中的“系统设置 > 固件更新 > 手动更新固件”部分。
进一步阅读
QTS 用户指南
QuTS hero 用户指南