Applicable Products
- QuTS hero h5.3.0 or later
- High Availability Manager
- Storage Manager
Scenario
During the initial paring of two NAS devices for high-availability (HA) cluster creation, the system checks whether the storage configurations of both NAS devices are identical, including connected JBOD enclosures. Even when the JBOD enclosure models, connected ports, installed disk slots, and disk capacities are consistent between the NAS devices, High Availability Manager may still report inconsistencies due to mismatched enclosure IDs, preventing HA cluster creation.
Root Cause
Enclosure IDs are usually assigned to expansion units in the chronological order that they are connected to the host NAS, starting from "1".
Even with identical JBOD enclosure models and configurations, connecting them to the two NAS devices in different chronological orders will result in mismatched enclosure IDs.
Solution
You can reinitialize enclosure IDs on both NAS devices. This assigns new enclosure IDs to the JBOD enclosures based on their physical connection order to each NAS device (that is, by port), instead of their chronological connection order.
- Ensure corresponding JBOD enclosures are connected to the same ports on both NAS devices.
This ensures that all JBOD enclosures are connected in the same physical order on both NAS devices. - For each NAS device, perform these actions:
- Log in as an administrator.
- Open Storage Manager.
- Go to Disks.
- Click ⋮ in the top-right corner of the Devices & Disks page, and then select Recover > Reinitialize Enclosure IDs.
The system assigns new enclosure IDs to the JBOD enclosures based on their physical connection order.
- After enclosure IDs are reinitialized on both NAS devices, open High Availability Manager to restart HA cluster creation.
Further Reading
适用产品
- QuTS hero h5.3.0 or later
- High Availability Manager
- Storage Manager
场景
在两个 NAS 设备进行高可用性(HA)群集创建的初始配对过程中,系统会检查两个 NAS 设备的存储配置是否相同,包括连接的 JBOD 机箱。即使 JBOD 机箱型号、连接端口、安装的磁盘槽和磁盘容量在 NAS 设备之间一致,High Availability Manager 仍可能由于机箱 ID 不匹配而报告不一致,从而阻止 HA 群集创建。
根本原因
机箱 ID 通常按照连接到主机 NAS 的时间顺序分配给扩展单元,从“1”开始。
即使 JBOD 机箱型号和配置相同,将它们以不同的时间顺序连接到两个 NAS 设备上会导致机箱 ID 不匹配。
解决方案
您可以重新初始化机箱 ID在两个 NAS 设备上。这会根据每个 NAS 设备的物理连接顺序(即按端口)而不是时间连接顺序为 JBOD 机箱分配新的机箱 ID。
- 确保相应的 JBOD 机箱连接到两个 NAS 设备上的相同端口。
这确保所有 JBOD 机箱在两个 NAS 设备上以相同的物理顺序连接。 - 对于每个 NAS 设备,执行以下操作:
- 以管理员身份登录。
- 打开存储管理器。
- 进入磁盘。
- 点击 设备和磁盘 页面右上角的⋮,然后选择 恢复 > 重新初始化机箱 ID。
系统根据物理连接顺序为 JBOD 机箱分配新的机箱 ID。
- 在两个 NAS 设备上重新初始化机箱 ID 后,打开 High Availability Manager 以重新启动 HA 群集创建。
进一步阅读