Why does OCR Converter fail to install with the error “Failed to create the PostgreSQL database. Reinstall OCR Converter” ?
Applicable Products
- All NAS Series
- QTS | QuTS Hero
- OCR Converter
Scenario
When trying to install OCR Converter, it fails with the error: "Failed to create the PostgreSQL database. Reinstall OCR Converter”.

Solution
OCR Converter database needs to use the TCP port 5018. If another application uses this port, the installation may fail. It is suggested to disable (or remove) any third-party applications that may be using the port, prior to install OCR Converter.
Further Reading
How to Use OCR Converter to Recognize and Extract Text from Images?
需要进一步协助,欢迎前往官方社区发帖,与其他用户及 QNAP 专家交流。 前往 QNAP 官方社区